Incident · Minor
Elevated load times on website
Resolved · Website
- Resolved
Website is live and operational with optimal performance.
- Monitoring
Applied a fix to the issue, monitoring for performance recovery.
- Identified
Cloudflare cache bottleneck with latest deployment
- Investigating
We are observing elevated load times of 100-200ms on our website. Our team is investigating the issue.